From Documentation

Jump to: navigation, search






Contents

Setting up on Eclipse

Here describes how to set up Maven on Eclipse

Prerequirement

  • JAVA SDK :
    Java 5 or above is required to run Eclipse and Embedded Maven (you can still use any Java version as default in Eclipse and run external Maven using Java versions required by Maven)
    Make sure Eclipse is running on JDK and not on JRE

Eclipse Related

  • Eclipse : 3.6 or later
  • Eclipse Plugin, which can be installed by using the Eclipse Update Manager. The Eclipse Update Manager can be found by selecting Install New Software... from the Help menu. Then, click Add... to add the URL as a new update site.
    1. M2eclipse[1]:
      Install Maven Integration for Eclipse (core feature)
      ZK Installation Guide m2e.png
    2. (Optional but recommend) Run-Jetty-Run
    3. (Optional) M2eclipse Extra[2]
      Install Maven Integration for WTP
      ZK Installation Guide m2e extra.png
    4. (Optional) Eclipse IAM, formerly Q for Eclipse:
      Eclipse Integration for Apache Maven
      Q4e on Google Code
    5. (Optional) Subeclipse
      Get the latest subclipse plug-in as per plug-in instructions here (use this http://subclipse.tigris.org/update_1.6.x)
      Note: For 64-bit Windows & 64-bit Eclipse installation you will need to install Silksvn client download to avoid JavaHL binding error.

  1. Official installation step
  2. This plugin should be installed when you use WTP as your development server.

Version History

Version Date Content
     




Copyright © Potix Corporation. This article is licensed under GNU Free Documentation License.